Pixel Create Account Viewing site as Guest - Click here to Login
Add Reply Search
#6533187 Aug 11, 2012 at 04:37 PM
38 Posts
Well, not quite how I wanted to start the weekend...

Went to watch something from my fileserver, on the PS3, and it just sat there doing nothing. Pressed stop, which responded instantly and back to the file-browser, so tried again with the same result.

Tried to SSH to the fileserver, nothing, although it was still pingable. So, tried plugging a monitor and keyboard into it, with absolutely no luck. Power-cycling was the only option left, so tried that...

As soon as it powered back up again, the monitor flickered into life, and I got the BIOS screen, went through the normal checks but the ominous feeling started when I saw it confirm the presence of three working disks (there are four in there), which was compounded by seeing the nice friendly "you have no operating system installed" error-message.

Now, given that the server is RAID-5, I'd assumed that losing a disk would be fine, and it would still boot up in a degraded state with all of the data intact - unfortunately, using software-RAID, it doesn't look like this is the case!

So, I now have 3 options, which I'll be trying in order:

1) Boot the system up, with three working drives connected, using a Linux LiveCD on USB key, and see if it can see any data.
2) Replace the broken drive, and see if the software-RAID system rebuilds the array from the three working disks.
3) Write off 2.3TB of data as lost and irretrievable (unless I fancy paying silly money for a company to do it - I don't), and rebuild the system with the new disks I've bought today, ie. the upgrade I was planning to do anyway (but preferably without losing all of the data in the process).

Fingers crossed #1 or #2 work, then I can make a backup of the data, and then go onto #3 without losing the data...
+0 Quote
#6533678 Aug 11, 2012 at 06:50 PM
281 Posts

Good luck
Admin monkey
Steam: Gazanimal | Yahoo Messenger: Gazanimal
+0 Quote
#6537154 Aug 12, 2012 at 02:21 PM
177 Posts
never fun.. :/

good luck m8
+0 Quote
#6544626 Aug 13, 2012 at 09:39 PM
38 Posts
Well, the first update in a hopefully-happy story: I tried option #1 (booting into a LiveCD with a USB stick), and it looks quite promising so far...

/dev/md0 (small RAID-1 array) is showing as "clean, degraded" which makes sense since it's a 4-way mirror across a 1GB strip of the four drives, so it's only missing 1 part of a 4-way identical segment of data.

/dev/md1 (RAID-5 array and most of the drive-usage) is showing as "active, degraded, Not Started" which, if I understand software-RAID correctly, means it's just pulled the array offline because it needs the repair carrying out (ie. broken disk removed, working disk replacing it, manual repair-process started).

The only worrying thing in the output was that /dev/md1 was showing as a 1TB array, whereas it should be 2.8TB, but I'm putting that down to the checker rather than the array being massively corrupted.

Will try replacing the disk tomorrow, as I don't fancy dragging two very heavy boxes out from storage to find my spare cooling-caddies to put one of the new drives in.
+0 Quote
Add Reply